7
$\begingroup$

In a recent Answer I posted on CV, I included markdown for a link, just like I have done thousands of times on CV and SO. This time the link text wasn't rendered as a hyperlink, either using the inline notation:

[link text](URL)

or the reference link notation:

[link text][1]
....
[1]: URL

Rendering links seems to be working just fine here on CV Meta. Have I lost the plot and gotten my syntax in a muddle or is there some other problem with CV's rendering?

I include the entire source for my Answer below to save you heading to CV to look at it. The Gelman et al 2008 part should be rendered as a hyperlink. The Answer uses the reference notation, but I've tried the inline notation as well with no luck.

Given the stated sample size (150,000), why do you think there will be bias due to "small sample" size? You have 1500 observations of the positive case, which I wouldn't normally think of as being *small*.

An alternative in R is the **brglm** package, which also implements Firth's method.

However, I was recently pointed to a paper [Gelman et al 2008][1] which showed Firth's method performing quite badly compared to other methods for bias reduction, in a Bayesian context. The authors of that paper wrote the `bayesglm()` function in R package **arm** to provide a range of priors on the model coefficients (Firth's method boils down to a particular choice of prior in the model; a Jeffreys prior). My main reason for mentioning it is that it may also work more efficiently than the options considered thus far.

(For some reason the markdown isn't rendering the link to the paper: http://www.stat.columbia.edu/~gelman/research/published/priors11.pdf‎)

[1]: http://www.stat.columbia.edu/~gelman/research/published/priors11.pdf‎
$\endgroup$
4
  • 2
    $\begingroup$ When I paste your text into an answer on the main site it does not work, but when I delete the link and use the link tool to recreate it it works just fine. The difference appears to be a matter of whitespace in front of the target [1]: http://.... $\endgroup$
    – whuber Mod
    Mar 26 '14 at 18:55
  • 1
    $\begingroup$ Don't know what happened, but after trying a couple of times, the link was fixed. $\endgroup$ Mar 26 '14 at 18:58
  • $\begingroup$ Thanks both; whatever you did @AndreSilva seems to have worked as now the inline notation works too. And in case you are wondering, I did check this again this morning before posting here and it wasn't working then :-) $\endgroup$ Mar 26 '14 at 19:02
  • 2
    $\begingroup$ I'm not sure what the problem is here. @whuber is right about the whitespace being finicky; you also need 2 blank lines (carriage returns) before the link references. But if I do that 1st, & then paste in your link reference, it still doesn't work. If I use the link tool, it works fine, even though I can verify that they are identical. Odd... $\endgroup$ Mar 26 '14 at 21:22
5
$\begingroup$

The problem was due to an invisible character in the end of the link URL.

Here is the revision history of this answer: https://stats.stackexchange.com/posts/91181/revisions. Scroll down to the Revision #1. At the moment I do see the link rendered (so, strictly speaking, I cannot reproduce the problem as reported), but it's broken: clicking on the link yields 404 error. Look at the URL of this 404 error:

http://www.stat.columbia.edu/~gelman/research/published/priors11.pdf%E2%80%8E

There are weird characters %E2%80%8E in the end. Erasing these characters opens the paper. What is interesting, however, is that if we look at the source code of this Revision #1 (https://stats.stackexchange.com/revisions/d51c2570-ea25-4bfa-afa5-98065623956a/view-source), we see this:

[1]: http://www.stat.columbia.edu/~gelman/research/published/priors11.pdf‎

This link appears to be fine, so one can wonder where did the weird characters come from. But in fact they are right there, just invisible. If you copy this URL from the source code (you can copy it directly from the above quote in this answer of mine) and paste it into the browser, you'll get to the 404 error and the same broken URL. That's because the invisible character gets copied.

So what is this invisible character? It is https://en.wikipedia.org/wiki/Left-to-right_mark

The left-to-right mark (LRM) is a control character (an invisible formatting character) used in computerized typesetting (including word processing in a program like Microsoft Word) of text that contains a mixture of left-to-right text (such as English or Russian) and right-to-left text (such as Arabic, Persian or Hebrew). It is used to set the way adjacent characters are grouped with respect to text direction.

Wikipedia says that its UTF-8 code is E2 80 8E.

How did it get into your link? You must have copy-pasted it from somewhere, possibly from a text editor.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .