5
$\begingroup$

I normally get to meta.stats.SE by either typing "meta." in the address bar or by clicking a link to meta in the sidebar - which might link to say http://meta.stats.stackexchange.com/?cb=1

But today I picked the link in the 'help' drop down in the menu bar on CV, which goes to:

https://meta.stats.stackexchange.com/

and got this (in Firefox):

This Connection is Untrusted

You have asked Firefox to connect securely to meta.stats.stackexchange.com, but we 
can't confirm that your connection is secure.
Normally, when you try to connect securely, sites will present trusted identification 
to prove that you are going to the right place. However, this site's identity can't be 
verified.

What Should I Do?
If you usually connect to this site without problems, this error could mean that 
someone is trying to impersonate the site, and you shouldn't continue.
meta.stats.stackexchange.com uses an invalid security certificate. The certificate is 
only valid for the following names: 
  *.stackexchange.com , stackexchange.com , meta.stackexchange.com , 
  *.meta.stackexchange.com , *.stackoverflow.com , stackoverflow.com , serverfault.com , 
  stackauth.com , sstatic.net , meta.serverfault.com , superuser.com , 
  meta.superuser.com , stackapps.com , openid.stackauth.com 
(Error code: ssl_error_bad_cert_domain)

Is this a problem my end or did somehow the site omit including this meta in its certificate?

Edit: I've just noticed different behaviour on CV itself - MathJax is still rendering fine when using http: to access CV but isn't working when I click any links that use https:; I wonder if that's related

One thought I've just had is this might perhaps be being impacted in some way by me running noscript in Firefox, but I've been running it for ages and never had this before.


Second Edit: This is weird. Now when I click the link in the 'help' menu in the bar at the top, it simply shows as meta.stats.stackexchange.com again and so works fine. If I type 'https:' in (as the link was going to before), it still gives the warning.

Since the main issue (clicking the link in the pull down 'help' menu generates the certificate warning) is no longer there, if it doesn't generate a response I may just delete this question soon.


(I included the tag bug since it seems to cover any unexpected site behavior, even though this may well be just my own issue.)

$\endgroup$
4
  • $\begingroup$ I use Firefox (version 26.0 currently). I just tried the link under help from the CV main page & I didn't get a warning message. (Of course, I don't know that that means there is necessarily a problem on your end.) $\endgroup$ Jan 14, 2014 at 3:56
  • 1
    $\begingroup$ @gung thanks. It's most likely just a temporary thing with me. I held off posting for a while to see if someone else posted... but then thought 'hang on, if everyone waits for someone else, an actual problem might go unreported'. Incidentally, the link in the top menu I mentioned now seems to have changed again so it doesn't use "https", so whatever the issue was, it's gone again. $\endgroup$
    – Glen_b
    Jan 14, 2014 at 4:05
  • $\begingroup$ are you sure you're not using any 3rd party stuff like https everywhere? SSL is still not officially supported, and we aren't generating any HTTPS links in the header. $\endgroup$
    – m0sa
    Jan 14, 2014 at 8:16
  • 1
    $\begingroup$ @m0sa It was certainly not happening everywhere. It only happened for about half an hour or maybe an hour and only on that one link that I described. Other links to meta on the same page at the same time worked fine (and were http: every time). No other sites outside SE I checked did anything like it. You could also see it was https by hovering over the link. I checked a bunch of stuff carefully before posting. $\endgroup$
    – Glen_b
    Jan 14, 2014 at 9:16

0

You must log in to answer this question.

Browse other questions tagged .